I can ping my droplet but cannot connect via browser

July 11, 2016 1.1k views
DNS

I am a newbie. I Have created a domain name registered it with my DigitalOcean droplet and I can ping it ok. But When i try to connect with my browser I just get the problem loading page screen. am i missing something or is it still a matter of waiting?

7 comments
  • Which distribution or one-click app did you install? You didn't tag those nor mention those in your question. Also, are you able to login in using ssh or the DO control panel?

  • Thanks for the reply
    i'm using Ubuntu 14.04.4 x64
    yes I am able to log in with ssh using direct address or my domain name.

  • @bssmithies - Log in via ssh and install lynx (a text based web browser) to try to access your web site locally.

    apt-get update
    apt-get install -y lynx
    lynx localhost
    

    If you can get to your web site, then you need to adjust your firewall. If you can't get to your website, and check your webserver software logs.

  • Yes! I have installed and run lynx and it works in the terminal. So what firewall settings do I have to change Local or on the server?
    Thanks again for your help.

  • @bssmithies - You're probably using ufw, so verify that it is active and which ports are enabled (at least your ssh port, port 22, should be open since you can ssh in)

    # look for Status: active, and ports 80/tcp and 443/tcp
    ufw status
    # if you don't see 80/tcp or 443/tcp, add them
    ufw allow 80/tcp
    ## port 443 is where https requests goes
    ufw allow 443/tcp
    

    [Edit: oops, this should have gone in the answer section]

  • I have done that but still no joy connecting!

    Status: active

    To Action From


    22 ALLOW Anywhere
    4444/tcp ALLOW Anywhere
    80/tcp ALLOW Anywhere
    443/tcp ALLOW Anywhere
    22 (v6) ALLOW Anywhere (v6)
    4444/tcp (v6) ALLOW Anywhere (v6)
    80/tcp (v6) ALLOW Anywhere (v6)
    443/tcp (v6) ALLOW Anywhere (v6)

    Thank you again for your help

  • I have cracked it now! I had to reinstall apache and everything is fine now. many many thanks for all your help!

2 Answers

This question was answered by @bssmithies:

I have cracked it now! I had to reinstall apache and everything is fine now. many many thanks for all your help!

View the original comment

This question was answered by @gndo:

@bssmithies - You're probably using ufw, so verify that it is active and which ports are enabled (at least your ssh port, port 22, should be open since you can ssh in)

# look for Status: active, and ports 80/tcp and 443/tcp
ufw status
# if you don't see 80/tcp or 443/tcp, add them
ufw allow 80/tcp
## port 443 is where https requests goes
ufw allow 443/tcp

[Edit: oops, this should have gone in the answer section]

View the original comment

Have another answer? Share your knowledge.