I can't access SFTP to PilotServer on my server, Webmin doesn't work, I can't upload files, help me please!

October 23, 2014 3.5k views

Hi, I have a VPS with ubuntu, I have connected it, added domain, app, database, changed password to SSH/SFTP.

SSH console works well.

But when I try to connect with Filezilla (I use host: mydomain.com, port 21, protocol SFTP, username serverpilot, password that I changed on ServerPilot panel control) I can’t, I have errors:

Status: Waiting to retry …
Status: Connecting to mydomain.com:21 …
Answer: fzSftp started
Command: open “serverpilot@mydomain.com” 21
Error: Network error: Connection timed out
Error: Unable to connect to server

And I can’t install webmin (I tried to install, on my previous configuration without ServerPilot it worked, with ServerPilot not).

mydomain.com:10000 doesn’t work (ERRCONNECTIONTIMED_OUT) but webmin is installed well

I can’t upload files, I can’t upload my forum…Please help me!!!!

1 Answer

SFTP listens on port 22, not 21 – try connecting to that port instead. As for webmin not loading, try running sudo netstat -plutn | grep 10000, does that output anything?

Have another answer? Share your knowledge.