Question

I can't connect to my droplet using putty or WinSCP, but in the digitalocean the username and password work

Posted June 29, 2020 372 views
Ubuntu

The title says it all, I can’t connect to my droplet anymore, it worked before but now i can’t access it via putty or WinSCP, it just says access denied everytime. How can I fix that?

1 comment
  • I still have not fixed this.

    • I checked for firewall,
    • I checked for “PermitRootLogin yes”,
    • I tried to add a SSD Key via the console, but I couldn’t, it won’t paste right into the console (the key),
    • I tried to uncheck the box for GSSAPI in putty. I tried to look at the log, it said: “Failed password for root from <my ip adress> port 58458 ssh2”, idk why port is 58458 tho, I tried to change it from 22 to 58458 in putty.

    Also please don’t forget I’m a very new beginner to linux in general, so it may be a really stupid error.
    The login i’m using is root, from looking for a solution i saw that is really bad practice to use password and root login, but that’s something I can change later if i’m able to access the droplet via putty and winscp.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hello,

Have you tried generating an SSH key for Putty and then adding this key toy our ~/.ssh/authorized_keys folder?

From what I understand there is access to your droplet however only by using the console. This would mean your SSH key is most probably incorrect or you don’t have one added from the system you are connecting to. In such a case as said, I’ll recommend generating the key with the Putty program and inserting it on your server.

Regards,
KFSys

  • I don’t have one and it worked before.
    However I did try to add a key withou any success before.

    I just tried again with a different method that involved using github to send my key file into the droplet, and and then echo the content into ~/.ssh/authorized_keys
    Probably a mess, but I now have access using putty and winscp

Submit an Answer