Question

I can't connect with ssh anymore

I use cent os 8.

I start delete some project whos actually was running.

After desconnection i cant any more to connect with ssh . I already have key host implemented.

I try :

ssh: connect to host MYDOMAIN.com port 22: Connection timed out

On the end i remove from digital ocean setting security keys…

Still no connect with ssh …

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Thank you for help . I fix it , it was fail2ban i added ip to ignore list …

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi there,

What I could suggest is double-checking if the Droplet that you are trying to SSH to is up and running. You can check that via your DigitalOcean Control Panel here:

https://cloud.digitalocean.com/droplets

Also if the Droplet is up and running I would recommend connecting via your Web console and see if the SSH service is running and make sure that port 22 is open.

Regards, Bobby

I use Ubuntu 20.04 (LTS) x64.

I start by updating a project.

After disconnection, I can no longer connect with ssh. I already have the key host implemented.

I try :

ssh: connect to host MYDOMAIN.com port 22: connection timed out.

Still no connection to ssh.

Hi @zlatnaspirala,

I know you’ve submitted the answer but still I wanted to clear in case anyone else stumbles on this question what are the standard reasons behind such issues.

  1. Network issue Your droplet might have experienced some network issue and making it offline. In cases like that, you can use your WebConsole to SSH to it and fix your problem. Additionally,@bobbyiliev gave a simple example that I always follow as well when want to check exactly that

  2. Firewall issue Like in this case, you could’ve block yourself out with a firewall rule you’ve added or a service like fail2ban. In this case, again you’ll need to use your WebConsole to SSH to your droplet and see exactly what’s going on.

  3. Droplet Compromised In some cases, when your droplet get’s compromised, DigitalOcean stops it’s traffic in order to prevent any HighLoad and bad outgoing traffic. These cases are very rare and you would’ve received an e-mail about this.

Regards, KFSys