Question

I can't establish a ssh connection to my server

as the title said:

I try to execute the command

$ nc -w 10 192.241.218.175 22 && echo true || echo false

and I got false


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I am also having this exact issue. I am doing ssh in windows through cygwin. Also tried it through Chrome ssh extension. <br> <br>Response from cygwin <br> <br>$ ssh root@128.199.218.65 -p 22 <br>Could not create directory ‘/home/admin/.ssh’. <br>The authenticity of host ‘128.199.218.65 (128.199.218.65)’ can’t be established. <br>ECDSA key fingerprint is 30:b3:9b:12:d5:f2:bd:30:a7:61:7b:c5:d7:50:22:82. <br>Are you sure you want to continue connecting (yes/no)? yes <br>Failed to add the host to the list of known hosts (/home/admin/.ssh/known_hosts). <br>root@128.199.218.65’s password: <br>Connection closed by 128.199.218.65 <br> <br>Response from chrome <br>Welcome to Secure Shell version 0.8.26. <br>Answers to Frequently Asked Questions: http://goo.gl/TK7876 <br>[Pro Tip] Use ‘Open as Window’ to keep Control-W from closing your terminal! <br>[Pro Tip] See http://goo.gl/TK7876 for more information. <br>Connecting to root@128.199.218.65… <br>Loading NaCl plugin… done. <br>Connection closed by UNKNOWN <br>NaCl plugin exited with status code 255. <br>®econnect, ©hoose another connection, or E(x)it? <br> <br>Please let me know the issue here. <br> <br>Thanks <br>Mrityunjaya

Your system appears up and responding to ssh connections <br>$ ping 192.241.218.175 <br>PING 192.241.218.175 (192.241.218.175) 56(84) bytes of data. <br>64 bytes from 192.241.218.175: icmp_req=1 ttl=57 time=76.0 ms <br>64 bytes from 192.241.218.175: icmp_req=2 ttl=57 time=75.8 ms <br>64 bytes from 192.241.218.175: icmp_req=3 ttl=57 time=76.1 ms <br>64 bytes from 192.241.218.175: icmp_req=4 ttl=57 time=75.6 ms <br>^C <br>— 192.241.218.175 ping statistics — <br>4 packets transmitted, 4 received, 0% packet loss, time 3000ms <br>rtt min/avg/max/mdev = 75.653/75.941/76.140/0.189 ms <br>$ nmap 192.241.218.175 <br> <br>Starting Nmap 5.21 ( http://nmap.org ) at 2014-03-07 18:10 EST <br>Nmap scan report for charmingwho.info (192.241.218.175) <br>Host is up (0.075s latency). <br>Not shown: 999 closed ports <br>PORT STATE SERVICE <br>22/tcp open ssh <br> <br>Nmap done: 1 IP address (1 host up) scanned in 1.53 seconds <br>$ ncat 192.241.218.175 22 && echo true || echo false <br>SSH-2.0-OpenSSH_5.3 <br>$ ssh 192.241.218.175 <br>The authenticity of host ‘192.241.218.175 (192.241.218.175)’ can’t be established. <br>RSA key fingerprint is cc:70:82:29:42:b6:e1:92:6a:0b:61:7b:c9:7a:7f:2a. <br>Are you sure you want to continue connecting (yes/no)?