Question

I can't open my Redis server in RDM.

I hosted a redis-server on my droplet, and cannot connect using RedisDesktopManager on my computer, someone please help.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Could be that remote connections are disabled. Enable it on your own risk, make sure you read warning bellow!

You can check redis.conf to verify is it enabled. There are to relevant settings, bind - by default it only allows connections from local, and protected-mode that makes Redis to reply only on queries from loopback interfaces.

To enable it, first open the conf file:

  1. sudo nano /etc/redis/redis.conf

For start find bind line. By default, it should be bind 127.0.0.1. To allow access from everywhere, you have to change it to bind 0.0.0.0. Next one is protected-mode. To enable remote connections set it to no: protected-mode no. Also, make sure lines are not commented, i.e. it doesn’t have `# in front of it. You are ready to save file and exit editor. To make changes in effect Redis restart is required:

  1. sudo systemctl restart redis

But please, be EXTREMLY CAREFUL! This is very dangerous, you must consider implementing AUTH method of if not, you are exposing your Redis instance to everyone on the Internet. As I said, it’s extremely dangerous to change above config, but if you have to do so, at least implement Auth. This Redis blog post can be helpful. Do it on your own risk!