Question

I can't renew certificates with letsencrypt certificates for my HTTPS ubuntu 16.04.

Posted June 5, 2017 9.1k views
ApacheLet's Encrypt

Hi!

I have tried to renew certificates and it just doesn’t seem to work. When I type in the command: sudo certbot renew I get

The following error was encountered:
[Errno 13] Permission denied: ’/var/log/letsencrypt/.certbot.lock’
If running as non-root, set –config-dir, –work-dir, and –logs-dir to writeable paths.
muna@Private-Server-Basic:~$ sudo letsencrypt renew
Saving debug log to /var/log/letsencrypt/letsencrypt.log


Processing /etc/letsencrypt/renewal/www.coffeeinnleyton.co.uk.conf

Renewal configuration file /etc/letsencrypt/renewal/www.coffeeinnleyton.co.uk.conf produced an unexpected error: ‘Namespace’ object has no attribute 'apache_enmod’. Skipping.


Processing /etc/letsencrypt/renewal/www.ionlinemarketing.co.uk.conf

Renewal configuration file /etc/letsencrypt/renewal/www.ionlinemarketing.co.uk.conf produced an unexpected error: 'Namespace’ object has no attribute 'apache_enmod’. Skipping.

No renewals were attempted.

Additionally, the following renewal configuration files were invalid:
/etc/letsencrypt/renewal/www.coffeeinnleyton.co.uk.conf (parsefail)
/etc/letsencrypt/renewal/www.ionlinemarketing.co.uk.conf (parsefail)
0 renew failure(s), 2 parse failure(s)

Any help would be appreciated! Thanks in advance

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

Hi @Muntansir

That’s very strange errors indeed. Can you run this sudo certbot --version

It might be easier to remove everything Let’s Encrypt and get new certificates again.

  • Thanks for the response!

    The certbot version is 0.14.2.

    Might be best to just remove and re-instate the certificates.

    Regards,
    Muna

    • Remember to remove the log folder, just to clean that out too:

      sudo rm -R /var/log/letsencrypt/
      

      I’m not sure if you can remove the entire /etc/letsencrypt/ folder and just run the certbot again or if you need to first uninstall certbot, then remove /etc/letsencrypt/ folder, then install certbot again.

      • Thanks!

        Will give this a try once I get home tonight and let you know how it goes.

        • So I have a habbit of breaking things in exceptional ways (kind of my talent).

          I managed to reinstall after a few days and the certificate is working however the website isn’t. I added on some packages to php7 and then removed the index file which was originally displaying however now when you go to the website it just downloads a file…

          I have a feeling it may be pointing to the wrong direction so will play around with the config file and hope that sorts it.

          • I managed to fix it!

            If you’re interested in the loading files the order was index.html etc etc etc index.php etc I had to move index.php to the front and it seemed to work fine after that!

            Want to say thank you so much for all of your help.

          • @Muntansir
            Hahah - that’s an excellent skill :)
            But great that you got everything working - that’s how you learn!
            If you need further help with anything, just create a new question here in the forum.

I am in a similar situation..ubuntu 16 First, my site was not showing not secure although letsencrypt certificate was valid. So I tried reinstalling certbot. I get an error apache plugin is not working…would love to uninstall letsencrypt and reinstall…any idea how I uninstall?

Submit an Answer