I can't type some symbols on console

July 3, 2014 17.6k views

Hi! First of all, I am newbie into servers configuration.
I am trying to installing wordpress. I have followed the tutorials about creating a droplet, installing LAMP and change domain name server to point to the DigitalOcean name servers and It was going pretty well.

But now I am stuck because I can't type some characters on the console, so I can't continue with the tutorials....

How can I type this two symbols? ~ <
And there is a way I can copy paste text on the console?

Thanks in advance!

2 comments
  • I'm having this exact same issue. Was a resolution ever found? One that doesn't involve Alt 1 2 4?

  • Same issue for me! Cannot type pipe | command. My MacBook does not have a numeric keyboard, so the alt ascii entries aren't working. Previously, I was able to just ssh in from terminal, but that isn't working. I'll have to liquidate my droplet and start over. :(

36 Answers

Alt + 1 2 4 should work.

  • That works, thanks - generates a |< but I just delete the < part and can then use the pipe section.
    Pain the ass though as can only use the keypad to generate the numbers...numbers top of keyboard dont do it.

    FYI - Vultr is the same for their console...although thats alot more responsive than DO......wonder if they will fix the console on DO to be repsonsive?

  • ATA BOY/GIRL/whatever!" for petbadgerand MattressWX, but you must use the keypad, and we are talking about a standard US MICROSOFT 104 key keyboard see Wikipdia for an image.

I have the same issue on a macbook 2018 with US keybaord. Shift + \ generates >, very frustrating and severely impacting my workflow. When will this be fixed?

Same issue here. Cannot use | and < on my macbook. Would like to see a fix soon as well.

I'll join the chorus of "can't type the | symbol". Using putty or ssh is fine, but I've secured my droplet with ssh keys. Occasionally I need to be able to access them to fix something from a location where I don't have those keys handy, and so the web console is my only option. I'm a bit hamstrung without the ability to type a pipe symbol.

I have the same issue with the pipe symbol | becomes >. I am trying to set up ssh on port 443 so I can use ssh because of blocked ports where I am at. So I have to use the web terminal until I get that fixed

for typing < use shift + control + < on keyboard mac.

Unfortunately, it is not possible to copy or paste text using the remote console. It's recommended to use the remote console only if you absolutely need it. Otherwise, you should use SSH to log into your droplet: How To Log Into Your Droplet with PuTTY (for windows users). Using an SSH client should allow you to type the characters you weren't able to type using the remote console.

by Etel Sverdlov
PuTTY is an open-source SSH and Telnet client for Windows. It allows you to securely connect to remote servers from a local Windows computer. This tutorial will cover how to connect to your Droplet from your local Windows computer using PuTTY.

Thanks Kamal! I had no idea of this and I have followed some tutorials doing this from remote console.

Can you explain your situation with typing certain symbols? I had no problem entering the < or ~ symbols on the DO web console.

I have no success with typing the pipe character "|". I can do it using my current keyboard, but the console translates that key to "<" instead. Any ideas?

This is a garbage set of circumstances. I can't type the less-than symbol because you can't correctly configure your servers. Great work Digital Ocean. Waste of my time.

Absolutely need this functionality right now. Doesn't seem to work in either the Firefox or Chromium browser I just tried. Can't do "|" or ">", which makes a lot of things really, really hard to do.

Same here, can't find the pipe symbol.

I'm trying to fix SSH access so console is the only way to access my droplet and I'm completely stuck.

I have the same issue via the console. US keyboard, type Shift+\ prints > instead of |

If I have to use the console because remote login is failing.. this kind of cripples my ability to effectively search / grep / etc. requiring me to send output to intermediate files.

I have the same problem using a Mac US keyboard with the VNC console and a CentOS 7 droplet. This isn't a problem so much with the remote/VNC part of things as much as it is configuring the Linux console to use the correct keyboard type. I tried a number of existing keymaps, but only found "us-intl" to be a bit better. I can type the pipe (|) symbol, but not <, >, or ^. If anyone finds (or creates) the right keymap file, please share!

The simple way to change your keycap is:

temporarily: loadkeys us-intl
permanently: localectl set-keymap us-intl

For more info: https://linuxconfig.org/how-to-change-system-keyboard-keymap-layout-on-centos-7-linux

I was having the same problem and I solve it by pressing 'Esc' two twice and '060' ascii code. I am working in mac and connecting to ubuntu server through digital oceans console and also using nano as text editor.

Same problem for me too. DO pls fix it asap.

Same problem.

I cannot type < or | , when I type them they produce ">" for both pipe and smaller than.

I have same issue , using in Windows.Please fix it asap as can not work with mysql commands

Same issue using Mac OS, cannot find |

Same issue.. Cannot able to type < character

Yes, I also can't get the pipe | or < to work. Even if I paste the command into the console, it converts it to >
Alt+124 does not work.

  • "ATA BOY!" for petbadger, but you must use the keypad, and we are talking about a standard US MICROSOFT 104 key keyboard see Wikipdia for an image.

oh man same problem with me,,, and same problem since 2014 !!! looks like must ssh to it

First, on a standard US Microsoft 104 key keyboard, petbadger's ALT+124 (must use the number pad) works. Clearly the terminal mapping is wrong for standard US Microsoft 104 key keyboard and the linux os reconfigurator does nothing. I don't have time or interest yet to play with the user profile. I usually work by terminal.
BUT HEY SUPPORT how about a fix or at least a one time profile fix when the user researches the problem on the boards.

This needs to need to be fixed and properly documented. In case of problems such as loosing ssh access to the VM or hacked VM that needs to stay offline until fixed it is mandatory to have a properly functioning keyboard on VNC, even with a US Keyboard there are keypads that doesn't work.
If you can't make all keyboard works please make at least one layout of widely available keyboard work and properly document which keyboard is compatible with your VNC.
That is unfortunately the kind of issues that makes it hard to recommend DO for production systems.

in my case I can't use the characters ~ ' (button on the top of Tab), <> near the right shift, and the | near the right shifts. The * button in the numeric keypad return 8 instead of *.
Those are mandatory characters to do basic sysadmin work.

Suffering from this myself, including when following a guide on how to fix missing SSH keys. This is such a frustrating problem. Even when right-clicking and pasting in, the wrong symbols are inserted.

https://www.digitalocean.com/docs/droplets/resources/console/

If you type directly into the console, it may initially read your number keys incorrectly, as if the SHIFT key is pressed. For example, pressing the 2 key may enter @.

This happens only when typing. You can avoid the problem by copying the text, then pasting it into the console by pressing CTRL + v. You can also reset this behavior and ensure that your key strokes are being received correctly by pressing SHIFT and CTRL a few times, then testing your number keys again.

How on Earth is this still an issue?

As a workaround, you can create a script in vi and enter the pipe character using Ctrl-k !! (so, Ctrl-k and then exclamation point twice).

I lost an hour trying to type in < character. Then I found this post.

OMG! How long has this been an issue!

Holy Hell, how the hell do you do this?

This is clearly completely idiotic and DO need to get their act together.

I found ANOTHER work around for if you don't have a number pad in windows (the numbers at the top don't work)

  • Open the on screen keyboard
  • Turn on the number pad
  • Hold alt on your physical keyboard (lol!)
  • Pres the number pad buttons on the onscreenkeyboard (124)

Wow...super dumb

Just fix this nonsense!

Have another answer? Share your knowledge.