Question

I can't upload a theme in wordpress. Increasing the upload_max_file_size hasn't helped.

Posted January 19, 2017 1.6k views
WordPressUbuntu 16.04

Pardon this newbie question as I am a strong tech guy, but I’m not familiar with this Linux (I’m working on it).

I performed the one click install of WordPress on Ubuntu 16.04.

Went through tutorial and now I can get into WordPress.

However, I can’t upload a theme. Here is what I have done.

  1. Increased the max upload file size to 100M. This was located in /etc/php/7.0/apache2/php.ini

  2. restarted apache2 services

What am I missing?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
2 answers

@scottmurray

What error are you seeing when trying to upload a theme through the WordPress Admin CP?

Hello all,

You can create a PHP info file in order to check the current values and check which is the php.ini file in use. Create the following file in your public_hmtl folder - phpinfo.php and put the following code inside it:

<?php
phpinfo();
?>

You can also use the following command in order to find the location of the php.ini file:

php -i | grep php.ini

The output will be:

Configuration File (php.ini) Path => /etc/php/7.2/cli
Loaded Configuration File => /etc/php/7.2/cli/php.ini

Then check for the current value of upload_max_filesize you can also check which is the configuration file - php.ini that is currently used and apply the changes there (if the site using the global php.ini file and you change the values for these settings this will make the changes globally for all sites). Ideally, you would like to have the following values:

upload_max_filesize = 64M

You also need to restart your web server in order for the changes to take effect.

Hope that this helps!
Regards,
Alex