I cannot access to my droplet by ssh or console after password reset

I have a CentOS droplet for which I had set up an ssh key. I have new computer, do not have the ssh key. I did a password reset, enter with putty, I am asked to enter a new password, which I do, and putty crashes after I hit enter after confirming new password. I tried several times, without success. So I tried via console in DO panel control, several times also. I enter new password, confirm, and the console asks me again to log in. If I try with new password, the login is incorrect. If I try with ‘old’ one (the resetted password), once again I am prompted to enter a new password, which I do, and the vicious circle continues… What is going on? should I destroy the droplet?


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Try doing the Password Reset while the server is turned off. It should automatically boot up the Droplet once the password has been reset.

If you are still unable to reset the password, submit a support ticket here: and ask support staff to boot the Droplet with Recovery ISO.

Once done, login to your server using Console Access and select option #1 to mount the filesystem and then option #5 to reset the password.