Question

i didn't get any html page while typing "curl --unix-socket /run/gunicorn.sock localhost"

As i am following through the tutorial https://www.digitalocean.com/community/tutorials/how-to-set-up-django-with-postgres-nginx-and-gunicorn-on-ubuntu-18-04

curl: (56) Recv failure: Connection reset by peer

i done everything perfectly according to that guide but i stuck on this command only ,before this all commands worked for me fine and gave expected outputs

please dont reply like check error logs, i am tired of checking error logs and asking questions in this community, your digital ocean team members just giving the constant reply “check error logs …” i am super irritated with your service ,even i replied with error logs in some of my previous questions you guys won’t reply to any of that

did you guys ever tested the documentation you provoided in your website its a total scrap

i recreated my droplet 3 times ant tried from begining


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I am stuck on the same problem, did you find a solution?

Is systemctl status ufw.service or service ufw status showing disabled for you?

Judging from your curl (53) error, it sounds like your client request almost made it to the “file description” (not file descriptor) behind the NIC, and its ready, waiting outside your server to begin reading bytes, but it’s never getting to that point.

If ufw is down, try running sudo service ufw start.