Question

I don't understand why my droplet is limited to 30% CPU

Good morning, From my droplet graphs, I don’t understand why the CPU doesn’t rise above 30%. I tried to do a resize with this feature: CPU-Optimized Dedicated CPU 4 vCPUs 8 GB 50 GB 5 TB $80/mo

https://ibb.co/Hp31YqF

but still the CPU doesn’t rise above 30%. The website having good traffic is very slow and I need to solve this slowness problem.

Thank you very much


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi @giordano,

It’s possible the issue is not coming from your Resources but from your configuration.

Are you using Apache or Nginx? It’s possible you are hitting the max workers allowed. Let’s assume you are using Apache. So first, what are Apache Workers, and what are they used for:

Imagine you are in a cinema, and there are 300 chairs inside. Those are the Apache Workers and the movie is your Website. If someone wants to watch the movie(your website) they need to sit in the chair (Apache Workers). If all 300 chars are taken, the 301 person needs to wait for someone to leave in order for them to sit and watch the movie. That’s how ApacheWorkers work. Once all ApacheWorkers are taken, a new person that wants to open your website waits for a spot to be open and only after that they can see your website.

Usually, these limits are set by 256 by default but they can be increased.

You can open your Apache configuration file. In there you should see something similar to:

ServerLimit 256
MaxClients 256
MaxRequestsPerChild 4000

Increase both the ServerLimit and MaxClients options, restart Apache, and see if this would solve your issue.

It’s possible they do not exist (haven’t been added) and the default values are the ones above. Adding them to the prefork content of apache mods should be fine as well.

Don’t forget to restart Apache afterward.