I followed the instruction to upgrade do-agent but it was failed

Posted October 14, 2019 1.4k views
DigitalOcean Accounts

I run this command

 curl -sSL | sudo bash

I got this error on the first attempt

Running hooks in /etc/ca-certificates/update.d....done.
Installing gpg key...OK
WARNING: The following packages cannot be authenticated!
E: There are problems and -y was used without --force-yes

On the second attempt, i was stucked at the last command below

Cleaning up old sources...OK
Verifying machine compatability...OK
Verifying compatability with script...OK
Installing apt repository...

Any solution ?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
1 answer


I would suggest running the following commands:

sudo apt-key update
sudo apt-get update

Then try again with the upgrade.

Let me know how it goes!

  • Sorry for the late reply. I have tried it but it failed on sudo apt-get update. This is the full output.

    Ign trusty InRelease
    Hit trusty-updates InRelease
    Hit trusty-backports InRelease
    Hit trusty Release.gpg
    Hit trusty Release
    Hit trusty-updates/main Sources
    Hit trusty-updates/restricted Sources
    Hit trusty-updates/universe Sources
    Hit trusty-updates/multiverse Sources
    Hit trusty-updates/main amd64 Packages
    Hit trusty-updates/restricted amd64 Packages
    Hit trusty-updates/universe amd64 Packages
    Hit trusty-updates/multiverse amd64 Packages
    Hit trusty-updates/main i386 Packages
    Hit trusty-updates/restricted i386 Packages
    Hit trusty-updates/universe i386 Packages
    Hit trusty InRelease
    Hit trusty-updates/multiverse i386 Packages
    Hit trusty-updates/main Translation-en
    Hit trusty-security InRelease
    Hit trusty-updates/multiverse Translation-en
    Hit trusty-updates/restricted Translation-en
    Hit trusty-updates/universe Translation-en
    Hit trusty-backports/main Sources
    Hit trusty-backports/restricted Sources
    Hit trusty-backports/universe Sources
    Hit trusty-backports/multiverse Sources
    Hit trusty-backports/main amd64 Packages
    Hit trusty-backports/restricted amd64 Packages
    Hit trusty-backports/universe amd64 Packages
    Hit trusty-backports/multiverse amd64 Packages
    Hit trusty-backports/main i386 Packages
    Hit trusty-backports/restricted i386 Packages
    Hit trusty-backports/universe i386 Packages
    Hit trusty/main amd64 Packages
    Hit trusty-backports/multiverse i386 Packages
    Hit trusty-backports/main Translation-en
    Hit trusty-backports/multiverse Translation-en
    Hit trusty-backports/restricted Translation-en
    Hit trusty-backports/universe Translation-en
    Hit trusty/main Sources
    Hit trusty/restricted Sources
    Get:1 trusty/main i386 Packages [14 B]
    Get:2 trusty/main Translation-en [14 B]
    Ign main InRelease
    Hit trusty-security/universe amd64 Packages
    Hit trusty-security/main i386 Packages
    Hit trusty-security/universe i386 Packages
    Hit trusty-security/main Translation-en
    Ign main Release.gpg
    Hit trusty-security/universe Translation-en
    Hit trusty InRelease
    Get:3 trusty-security/main Sources [172 kB]
    Get:4 trusty-security/universe Sources [102 kB]
    Hit trusty/main Sources
    Get:5 trusty-security/main amd64 Packages [835 kB]
    Ign main Release
    E: Method https has died unexpectedly!
    E: Sub-process https received signal 9.
    • Hello,

      Would you mind confirming your exact Ubuntu version? You can check that by running:

      sudo cat /etc/os-release

      The error is making me think that you are either using an old Ubuntu distro or that something is wrong with your libcurl.


      • NAME="Ubuntu"
        VERSION="14.04.3 LTS, Trusty Tahr"
        PRETTY_NAME="Ubuntu 14.04.3 LTS"
        • Hello,

          Yes, Ubuntu 14.04 is no longer going to be supported so that would explain why the installation is failing.

          I would recommend upgrading to a newer version which would include all of the new security patches and all of the packages as well.

          Hope that this helps!