Question

I have a wordpress cluster and need to increase maximum execution time to install my theme

Hi,

I am totally lost, I have the WordPress cluster and I am asked to edit some files wp-config.php; .htaccess and/or php.ini.

I understand that I need to connect via FTP via Filezilla and then modify the files with the text editor, but I am not able to connect via FTP, not sure if the address is the one from the WordPress database or from my Droplet, and what passwords to use.

Any help would be super appreciated!

Best regards,

Miguel


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello there,

You can create a php info file in order to check the current values and check which is the php.ini file in use. Create the following file in your public_hmtl folder - phpinfo.php and put the following code inside it:

<?php
phpinfo();
?>

You can also use the following command in order to find the location of the php.ini file:

php -i | grep php.ini

The output will be:

Configuration File (php.ini) Path => /etc/php/7.2/cli
Loaded Configuration File => /etc/php/7.2/cli/php.ini

Then check for the current value of max_execution_time you can also check which is the configuration file - php.ini that is currently used and apply the changes there (if the site using the global php.ini file and you change the values for these settings this will make the changes globally for all sites).

You also need to restart your web server in order for the changes to take effect. Additionally, a restart of the php-fpm restart is also needed.

Hope that this helps! Regards, Alex

Hi there,

In order to connect to the server using FileZilla, you could use SFTP rather than FTP. You can follow the steps here on how to do that:

https://docs.digitalocean.com/products/droplets/how-to/transfer-files/

For modifying server files like php.ini I would recommend using SSH and a terminal text editor like nano or vim. If you need to do that, you could follow the steps here on how to connect via SSH:

https://docs.digitalocean.com/products/droplets/how-to/connect-with-ssh/

If you are not familiar with the Linux terminal, I would recommend following the steps from this tutorial here:

https://www.digitalocean.com/community/tutorials/an-introduction-to-the-linux-terminal

Let me know how it goes! Regards, Bobby