Question

I have errors with logging into mysql ser

I installed mysql server yesterday on my droplet, it worked properly yesterday but today I tried logging into the mysql $ mysql -u root -p and it throws an error (ERROR 2002 (HY000): Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2) ).
Please I need help with this, it’s my first time deploying on digital ocean and I don’t know how to solve this particular issue, all help from the internet seem not to work and I’m pressured for time to get it working, please help me.

thanks.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello,

You would need to make sure that MySQL is up and running before you could access it. To check the current status run:

systemctl status mysql

Then if the service is not active, you can start it with:

systemctl start mysql

After that you should be able to login as normal.

Hope that this helps! Regards, Bobby