i have uploaded file index.html into public_html but it only shown It Works! page ?

May 9, 2016 650 views
Nginx Control Panels

Hi ,

I'm currently using VestaCP and Ubuntu 14.04.4 x64 with Advanced Install Settings.

2 Answers


Can you copy the config at /etc/nginx/sites-available/default into a pastebin, please? You can remove the domain name if needbe.

  • Hi mate,

    i have find the directory but unfortunately i can't find config file



    • Alright, there should be a sites-available folder and a sites-enabled folder in the nginx directory, and the file will be named default, it doesn't have an extension after the name unlike nginx.conf

      If there isn't at all of either site folders, than it may just be nginx.conf

Do you have a .htaccess file? if check the default something like this:

#Alternate default index page
DirectoryIndex first.html
Have another answer? Share your knowledge.