I just set up postfix on the server but emails could not be received.

August 23, 2015 916 views
Email DigitalOcean Ubuntu

I've followed this guide step by step and tested sending my email from my gmail to both and But the emails could not be delivered.

I have added felix in sudo /etc/postfix/virtual step.

Could it be because I did not add any MX records?

2 Answers

yup. You need to add MX records.
Probably works if you send it via a local account to hello@localhost

A protip is to also add rDNS for your server. That reduces the risk to your emails being marked as spam by other servers (like Gmail for example)

  • Oh and you can't just use Postfix. You need to use something else that handles the imap & pop3 requests. Like Dovecot.

    Also, setting up a own email server is something really hard to do. If you're not familiar with ubuntu servers and DNS records I suggest you find a email host or try out an easier setup. Postfix is not the easiest out there.

    This tutorial looks fairly simple:
    Even if it's not based on a digitalocean server the process should be pretty much the same. Except from the DNS then of course. That should be handled via the digitalocean control panel in order to get rDNS.

  • Hey @carl279820 I went to google DO rdns and found a 4 steps guide for rDNS by DO FAQ. Not sure if it's correct. I checked the mxtools for the reverse lookup and it worked.

You can try another tutorial for mail server for Ubuntu 14.04

I used this article to successfully create a mail server on Ubuntu 14.04

Have another answer? Share your knowledge.