Question

I mad a minecraft server, but nobody can connect with it. I cant connect either when im not connected through SSH

Posted October 15, 2014 3.4k views

Hi, i made i minecraft server following this tutorial, but nobody can connect to it. When i’m not connected to the server through PuTTy i can’t connect either. What am i doing wrong?

Im running it on ubuntu 14.04. I tryed turning of the firewall through '$ sudo ufw disable', which did turn the firewall off but i still couldn’t connect, neither could my friends. I also tryed opening the specific ports for the server.

I also tryed following this tutorial but that didnt work either. I then reset my system, tryed the first tutorial again, but still nothing.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Can you give me the output of these 3 commands, please?

netstat -plant
ps auxf|grep minecraft
ufw status
  • Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name

    tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 1694/sshd

    tcp 0 0 0.0.0.0:5355 0.0.0.0:* LISTEN 1419/systemd-resolv
    tcp 0 68 174.138.66.181:22 58.218.198.142:25018 ESTABLISHED 19113/sshd: root [p
    tcp 0 232 174.138.66.181:22 75.155.216.140:50612 ESTABLISHED 18986/sshd: root@pt
    tcp6 0 0 :::22 :::* LISTEN 1694/sshd

    tcp6 0 0 :::25565 :::* LISTEN 18814/java

    tcp6 0 0 :::5355 :::* LISTEN 1419/systemd-resolv


    root 19121 0.0 0.0 12960 1028 pts/0 S+ 14:34 0:00 _ grep –color=auto minecraft
    root 18814 2.5 21.4 3534992 438368 pts/1 Sl+ 14:04 0:45 _ java -Xmx1024M -Xms1024M -jar minecraft_server.jar nogui


    Status: inactive

    • UFW isn’t blocking. Service is up. It is listening on the default port. Check your config. Some server solutions have a setting to not allow connections if you don’t change the config.

Submit an Answer