I need help

November 1, 2013 1.5k views
I need help!! I installed CentOS release 6.4 (Final) and then installed ruby 1.8.7 (2011-06-30 patchlevel 352) [i386-linux] but now I can not install ruby 1.9.2 can anyone help me?
2 Answers
Remove old ruby, install new ruby from sources. Don't bother with the distribution's packages.
ok ...
when I try to remove the ruby 1.8.7 it tries to remove dependencies also ...
ruby 1.8.7 installed by yum

how can I do to remove only the ruby? and maintaining the dependencies
Have another answer? Share your knowledge.