Question

I need help regarding deployment of a Laravel App

Posted December 25, 2021 133 views
Laravel

I tried to deploy Laravel App using App Platform but when I connect to github, it says “Sorry, we couldn’t find an app in your repo”. Please help me out to fix this issue.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
1 answer

Hello,

Do you have your composer.json file committed to the root directory of your GitHub repository?

The App Platform will look for that file in order to identify the project and proceed with the automated builds.

Best,
Bobby

  • Hi, I’m developing this app. Yes I have composer.json file on root directory of the project. Everything was working fine few weeks ago. It happened suddenly. I even tried another project too but it’s not working.

    • Hi there,

      Is the app open source? If so could you share a link to the repository itself?

      If not, could you share the composer.json file here in case that it does not contain any sensitive information?

      If this is not possible either, have you tried revering back any changes made to the file or the project back to when it was working and comparing what has changed?

      Regards,
      Bobby

      • Here is the composer.json code below.

        {
            "name": "laravel/laravel",
            "type": "project",
            "description": "The Laravel Framework.",
            "keywords": [
                "framework",
                "laravel"
            ],
            "license": "MIT",
            "require": {
                "php": "^7.3.5|^8.0",
                "anhskohbo/no-captcha": "^3.3",
                "beyondcode/laravel-websockets": "^1.12",
                "doctrine/dbal": "2.*",
                "facebook/graph-sdk": "^5.7",
                "fideloper/proxy": "^4.4",
                "fruitcake/laravel-cors": "^2.0",
                "guzzlehttp/guzzle": "^7.3",
                "jackiedo/timezonelist": "^5.0",
                "laravel/framework": "^7.29",
                "laravel/socialite": "^5.2",
                "laravel/tinker": "^2.5",
                "laravel/ui": "^2.4",
                "pusher/pusher-php-server": "~3.0",
                "socialiteproviders/instagram": "^4.1",
                "socialiteproviders/instagram-basic": "^4.1",
                "stripe/stripe-php": "^7.91"
            },
            "require-dev": {
                "facade/ignition": "^2.0",
                "fakerphp/faker": "^1.9.1",
                "mockery/mockery": "^1.3.1",
                "nunomaduro/collision": "^4.3",
                "phpunit/phpunit": "^8.5.8|^9.3.3"
            },
            "config": {
                "optimize-autoloader": true,
                "preferred-install": "dist",
                "sort-packages": true
            },
            "extra": {
                "laravel": {
                    "dont-discover": []
                }
            },
            "autoload": {
                "files": [
                    "app/Helpers/misc.php"
                ],
                "psr-4": {
                    "App\\": "app/"
                },
                "classmap": [
                    "database/seeds",
                    "database/factories"
                ]
            },
            "autoload-dev": {
                "psr-4": {
                    "Tests\\": "tests/"
                }
            },
            "minimum-stability": "dev",
            "prefer-stable": true,
            "scripts": {
                "post-autoload-dump": [
                    "Illuminate\\Foundation\\ComposerScripts::postAutoloadDump",
                    "@php artisan package:discover --ansi"
                ],
                "post-root-package-install": [
                    "@php -r \"file_exists('.env') || copy('.env.example', '.env');\""
                ],
                "post-create-project-cmd": [
                    "@php artisan key:generate --ansi"
                ]
            }
        }
        
        edited by bobbyiliev
        • Hi there,

          I just tested this composer.json file and it looks like that the app platform detects it as a PHP project:

          Is your code is in a subdirectory? If so you will need to configure the Source Dir option to point to the subdirectory.

          Alternatively, you could open a support ticket and include the link to your repo and we can take a closer look into why the process is failing. You can also share a specific commit if you wish.