I one click installed ruby on rails. Now what?

I created a digital ocean droplet, and one-click installed ruby-on-rails. I SSHed into the server, and found that I have one ruby on rails project called example. Ok… It seems that this application is what’s running when I type in the IP address of the droplet into google. But, I want to upload my own website, not just keep an example application obviously…

So I git cloned a repository from bitbucket which contained a finished ruby on rails website. I tried running rails db:create and it failed… apparently, there was a lot of stuff not installed yet… which is weird because I thought that one-click install handled all of that. I tried running bundle install and I had to install bundler of course… Once I installed bundler and ran bundle install, the installation failed once it got to the nokogiri gem. I also saw that when I ran bundle install on the example project, the same thing occurred. The installation failed when it reached nokogiri, but the example app still ran in the browser without errors… huh.

So I deleted the example project, leaving my rails website as the only project in the rails directory on my droplet and when I refreshed the page, I got a big error saying that the example application was missing… What??? It always looks for the example app??? Whatever… I renamed my website directory to example and refreshed the page and now I’m getting this error:

Errno::EACCES Permission denied @ dir_s_mkdir - /home/rails/example/tmp/cache

So now I’m super confused… I tried looking online for some documentation, but all I can find is how to install Ruby on Rails on a droplet… So, I don’t know what to do.

Any help is very appreciated. If you have some articles or documentation links explaining how to actually deploy a ruby application to a droplet which had ruby on rails installed by default, I’d love to see them. Thank you very much! :)

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

The documentation for the one-click app is as close to useless as they come. I ran into the same issues the last time I tried using the one-click approach. Hopefully someone will respond with an answer for you, and will update the docs.