Question

I Power Cycle-d My Droplet and Now it Won't Turn on!

Hi everyone,

I’ve encountered an error during a routine Power Cycle, and now I’m getting the message, “Powering on Droplet Issue.”

Full text reads: Sorry, we had a problem turning your Droplet on. Please try again.

No further details are provided. The first half of the power cycle (turning the droplet off) seems to have worked fine, which means I’m at DigitalOcean’s mercy here – I’m not sure what I can do, beyond continuously trying to Turn On the Droplet and expect a different result.

I’ve filed a Support ticket as well, but writing this here as well in case others have had similar issues in the past and can share how they resolved it! Any help is welcome here, thank you!

running 8 GB Memory / 160 GB Disk / Ubuntu


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi @mitch66ad0a10ac463f366b1ff,

It would be really hard to pinpoint the exact issue. What you can try is to boot your Droplet with a recovery console to see the exact issue.

Otherwise, what else I could help you out with is if you provide me with the ticket reference to try and speed up the answer for support.