Question

I reinstalled Apache in my WordPress install without backing it up and now my site is not working

Hello,

I was enabling http/2 and I for some stupid reason reinstalled Apache without backing up it’s files.

I spent a lot of time now trying to recreate the Apache files that were automatically generated when I created this WordPress install via 1 click install, to no avail.

I am trying to figure out how to get the files I need to get this Droplet working again.

  • Right now I’ve got apache up and running, I’ve enabled AllowOverride All in apache.conf:
  • I also ran a2ensite mydomain.com as well
  • I added ServerName mydomain.com to the 000-default.conf in sites-available fire

I also downloaded apache files from other droplets that are working and tried to re-create the same feel, no luck. Apache is not showing anything in error logs

Could you please point me where should I look and what should i do to T/S this since my site is still not loading?

Thank you


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Thank you @jarland and @X40C for contribution!

What ended up being and issue is next error message:

Considering conflict mpm_event for mpm_prefork:
ERROR: Module mpm_event is enabled - cannot proceed due to conflicts. It needs to be disabled first!

Leaving that just in case someone else has the same/similar issue :)

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Go to https://mxtoolbox.com/DNSLookup.aspx and check both domain.com and www.domain.com and verify if they both have the same ip address(your droplet’s ip address).

Hey friend,

Sounds like you’ve been busy and making a solid effort on this. Maybe I can help you look at it differently. At this point I think let’s break away from trying to make the configs match their original, and focus on the current state of it. What is currently happening that causes this to not work? Describe to me where the live result breaks from the desired result, and what that looks like from your perspective. Error messages, etc.

Focusing on the current state and moving forward from there will probably put us on the right path.

Jarland

Hello.

How about taking the backup of WordPress content and database through terminal (assuming the files still exists)?

Then you can migrate the whole site to the new droplet.

Praveen!