I've tried to run Nginx Ruby On Rails Ubuntu 16:04. I'm facing the same issue with both solution I tried.

January 31, 2018 1.4k views
Ruby on Rails Nginx One-Click Install Apps Ubuntu 16.04

I follow steps from the blog. Some steps cause me lot of troubles. So move to One-click Install Ruby On rails droplet. It works with the default project. But I want to run my project, using the sites-enabled conf.

All file are uploaded to :
1- /var/www/metribook/epicure-app
2- in /etc/nginx/sites-enabled I changed the default site config to the one in 1)
3- I got the same error when I restart nginx service with sudo: sudo service nginx restart
error: Job for nginx.service failed because the control process exited with error code. See “systemctl status nginx.service” and “journalctl -xe” for details.

I got the same error with the first Droplet. I already install Nginx with Passenger many times on EC2 but I cannot resolve this issue. Need some help.

Be the first one to answer this question.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!