Question

I want both www.* and the root domain to point at my Ghost blog. How do I do this?

  • Posted September 10, 2014

Currently, only http://www.karimmaassen.com goes to my Ghost blog. http://karimmaassen.com fails. How do I fix this?

Subscribe
Share

What Webserver are you on (NGINX, APACHE)? does your configuration file look like this?

If your on UBUNTU

NGINX: (/etc/nginx/sites-enabled) server_name karimmaassen.com *.karimmaassen.com www.karimmaassen.com;

After you configure: service nginx restart

APACHE:(/etc/apache2/sites-enabled) ServerName www.karimmaassen.com ServerAlias karimmaassen.com *.karimmaassen.com

After you configure: service apache2 restart

That resolved the issue! If you could make it into a real answer, I’ll mark it as answered!

@juhenriquez - Thanks for your comment. I’m running the application droplet of Ghost, which is I believe Nginx?

I’ll try and edit my sites-enabled file.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

What Webserver are you on (NGINX, APACHE)? does your configuration file look like this?

If your on UBUNTU

NGINX: (/etc/nginx/sites-enabled) server_name karimmaassen.com *.karimmaassen.com www.karimmaassen.com;

After you configure: service nginx restart

APACHE:(/etc/apache2/sites-enabled) ServerName www.karimmaassen.com ServerAlias karimmaassen.com *.karimmaassen.com

After you configure: service apache2 restart