Im using 1&1 with digitalocean so i can enter the server with a web name but i still cant!

February 13, 2017 285 views
DigitalOcean

Hi! I actually payed for it. For Security reasons i cannot give much information but i will give as much as i can. I bough a domain .com for a year and what i want to do is that when i put in the web the domain, the things of the ip of digital ocean appears : like that:
My digital ocean ip : 44.44.134.123 (EXAMPLE)
WEB NAME: digitaltesto.com

I want to put digitaltesto.com and want to see all the things from 44.44.34.123,

The problem actually is that i only can access my server writing that:
44.44.134.123:8080
And it seems i need to access with port 80, i added to the interface , refresh, restart things.. and still nothing.
My teacher said something about if port 80 was watching at netstat at it seems that it wasnt. But i didnt get helped anymore.

So how can i make to enter to the server with the port 80 or some that i dont have to write, so i can enter trough digitaltesto.com?
Thanks for your time

1 comment
2 Answers

Change the port of your application to 80 or use a webserver as a proxy.

@jorgehurtadodmx

How you'd go about changing the port(s) that the web server is listening on depends on the web server itself.

If you're using Apache, then you'd need to modify the VirtualHost for the domain and change what I would assume looks like:

<VirtualHost *:8080>
...
...
..
</VirtualHost>

to

<VirtualHost *:80>
...
...
..
</VirtualHost>

If you're using NGINX, you'd need to modify the server block for your domain, which I would assume looks like:

server {
    listen 8080;
    listen [::]:8080;

    ....
    ....
    ....
}

to

server {
    listen 80;
    listen [::]:80;

    ....
    ....
    ....
}

You'd then restart the web server for the changes to take effect.

  • I tough i may be using apache, but tried searching bot and I cant find where to configure that :(

    Its centos7

    • @jorgehurtadodmx

      The standard installation path for Apache and NGINX will be /etc -- for example:

      /etc/apache2
      

      and

      /etc/nginx
      

      Your configuration files would be in the sites-available or sites-enabled directory.

      • I dont have any file like sites-available etc so ...

        i managed make it work going to httpd conf and changing Listen 8080 to Listen 80
        I have 1 Joomla and 2 Wordpress, one of the wordpress is still redirecting to :8080

        • @jorgehurtadodmx

          With WordPress, make sure you check the settings for your URL's via ./wp-admin. If you installed WordPress when Port 8080 was attached to the URL, then that's the URL that WordPress will use until it's changed. Once you save the settings, it'll log you out, but it should allow you to set the URL without the port.

          Beyond that, since that appears to be a custom setup, I'd have to know more about how you've setup Apache as normally, when it's installed using a package manager, those are the directories where it'd be installed to.

Have another answer? Share your knowledge.