Question

Importing CSV files into pgAdmin 4 - Utility Not Found - Ubuntu 18.04

Posted January 27, 2019 1.5k views
PostgreSQLDjangoUbuntu 18.04

I am unable to import my CSV files into my PgAdmin 4 in Server Mode.

I have successfully completed How To Install and Configure pgAdmin 4 in Server Mode, which is working great.

Additionally, I have migrated my Django models successfully, which are showing up within my pgAdmin in Server Mode. Again, this is working great.

However, when I go to import the csv files into pgAdmin to populate the Django models, I am getting prompted with a Utility Not Found Error: File Not Found

I HAVE GONE THROUGH THE PROCESS ON CONFIGURATION TO SET UP THE BINARY PATH TO DIFFERENT PATHS including “/var/lib/postgreql/database.bak”, ’/etc/postgresql/10/bin’, and several other variations. There is no issue with inputting the path, but I am not creating the correct one.

“Please correct the Binary Path in the Preferences dialog”

The answers I have found online, are only providing guidance for local server settings (i.e. C:/ProgramFiles/postgresql/10/main/bin) and do not cover the Digital Ocean server that was created. All information that I can find related to Digital Ocean are on creating backups, migrating data and DO NOT DIRECTLY COVER THIS ISSUE.

Has anyone resolved this question? Do you know how I can find the correct binary path to import my csv files?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Was able to find the answer

Binary Path should be set to: /usr/bin

Submit an Answer