Impossible to access vestaCP or AjentiCP on a fresh uBuntu install

Hello everyone !

I wanted to install a control panel on my droplet (currently running ubuntu 14.04 with a LEMP stack) and I’m basically stuck.

I first installed ajenti, and I had no problem during the installation, but I cannot access the control panel from my home computer, I get a connection time out instead, from both chrome and firefox. After a while I tried installing vestaCP instead, and I have the exact same issue. I then decided to try with a fresh ubuntu 14.04 install, and lo and behold, still the same connection time out with ajentiCP and vestaCP. Then I tried the same with a fresh ubuntu 12.04 install, and I still cannot make it work.

Here’s a few informations on what I tried :

  • I tried several installation following the tutorials from DigitalOcean and the official guide from ajenti/vesta websites, each time the installation goes fine, no error reported
  • I tried every combinations I could think of : ajenti alone on ubuntu 14.04, vestacp alone on ubuntu 14.04, ajenti and vestacp together on ubuntu 14.04, and the same thing on ubuntu 12.04
  • on every installation the service seems to be running correctly, and if I do a grep 8000/8083 on netstat I get :
tcp 0 0* LISTEN 21340/vesta-nginx


tcp 0 0* LISTEN 20948/python

The “” seems weird, so I changed the “host” ip address in /etc/ajenti/config.json with my droplet ip address, after restarting the service netstat shows the correct IP address but I still get connection time out

  • all those tests were done on fresh install, nothing else than vesta/ajenti was installed, I didn’t even create a user account apart from root
  • I double-checked and triple-checked that I entered the correct IP address, and that I was in https
  • I disabled ssl mode in ajenti and try to connect to http://myipaddress:8000, still nothing
  • I tried in incognito mode in chrome to be sure that no extensions were causing this
  • I even tried turning it off and on again…

And now, I’m completely out of ideas. I never installed a firewall on my droplet, and I don’t think there’s one in the basic ubuntu image apart from ufw (which I disabled just to be sure). I have absolutely no idea why it doesn’t work, and I’m afraid it’s something really simple that I just haven’t thought about. Anyone ever had any problem like this ?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Well disregard all of this, I just tried from a friend’s computer and it worked, so that must come from my home computer…