Question

In a WordPress DigitalOcean droplet which version of phpmyadmin should I install to avoid errors?

I have a DigitalOcean WordPress droplet (https://marketplace.digitalocean.com/apps/wordpress), and I need to install phpmyadmin. Following these instructions: https://www.digitalocean.com/community/tutorials/how-to-install-and-secure-phpmyadmin-on-ubuntu-20-04, when I login into the phpmyadmin after the installation, I noticed that the version is 4.9.5 and while viewing the WordPress database (for example) I get the “Some errors have been detected on the server” message.

And this is what I see:

Deprecation Notice in ./libraries/classes/Di/ReflectorItem.php#82 Method ReflectionParameter::getClass() is deprecated

Backtrace

./libraries/classes/Di/ReflectorItem.php#50: PhpMyAdmin\Di\ReflectorItem->_resolveArgs( array, array, ) ./libraries/classes/Di/FactoryItem.php#27: PhpMyAdmin\Di\ReflectorItem->invoke(array) ./libraries/classes/Di/Container.php#62: PhpMyAdmin\Di\FactoryItem->get(array) ./libraries/classes/Di/AliasItem.php#44: PhpMyAdmin\Di\Container->get( string ‘PhpMyAdmin\Controllers\Database\DatabaseStructureController’, array, ) ./libraries/classes/Di/Container.php#62: PhpMyAdmin\Di\AliasItem->get(array) ./db_structure.php#35: PhpMyAdmin\Di\Container->get( string ‘DatabaseStructureController’, array, )

searching online, I found out that the installation didn’t add the latest available version of phpmyadmin, and some people suggested upgrading the version of phpmyadmin to something greater than version 5.

So my question is how do I fix these errors? Does upgrading to a newer version will fix the problem? What’s the best approach to fix this problem?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hello,

I would suggest installing the latest version just to make sure that you have the latest security patches as well.

To do that, you can follow the steps on how to install PHPMyAdmin manually here:

https://www.digitalocean.com/community/questions/how-to-install-manually-phpmyadmin-on-ubuntu

Hope that this helps!

Best,

Bobby