Question

In app platform a custom domain was configured but no HTTPS certificate generated, how come?

I created an app based on a docker container image from a digital ocean registry. The apps works fine on the domainname provided by the app platform. This domain name is something like https://<name-of-app>-<hash>.ondigitalocean.app/. As said the app works fine.

In settings I enabled a ‘custom’ domain, lets call it: https://myapp.example.com . A the domain name is managed by digitalocean and I can see that the platform created a CNAME record myapp.example.com IN CNAME <name-of-app>-<hash>.ondigitalocean.app 1800. However in the settings I can see that this new domain is stuck ‘configuring’ for days now. I guess it is stuck in the creation of the https certificate.

When visiting https://myapp.example.com I see that I get a response: “The site does not support a secure connection. myapp.example.com uses an unsupported protocol. ERR_SSL_VERSION_OR_CIPHER_MISMATCH” (message from a chrome backed browser - other browsers give similar message. SSLlabs reports it cannot communicate with the server securely well.)

I tried several different apps, but all seem to fail. Also it does not matter if i tried ‘basic’ setups (testing) or ‘production’ setups. It is in the AMS3 region.

I suggest something is wrong in the cert manager of either digital ocean app platform bound to the region. (hmm I could try another region as well indeed)


Submit an answer


This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

KFSys
Site Moderator
Site Moderator badge
February 23, 2023

Hey @jochemberends,

If you are using the DigitalOCean App Platform this is all done automatically. With the App Platform, DigitalOcean creates, manages, and renews your SSL certificates automatically.

If that isn’t the case and when you configure your custom domain, it’s stuck on pending for days, I’ll recommend contacting DigitalOcean’s support. Please reach out to our amazing support team who will be more than happy to assist you with your account issue! :)

https://www.digitalocean.com/support/

Hope that helps! - KFSys.

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel