Increase innodb_buffer_pool_size prohibited

September 22, 2014 1.5k views

Hi There,

Ive been trying desperately to have my innodb_buffer_pool_size increased from the current 2G to 10G. And all the while I have been receiving the following...

140922  9:33:48 InnoDB: The InnoDB memory heap is disabled
140922  9:33:48 InnoDB: Mutexes and rw_locks use GCC atomic builtins
140922  9:33:48 InnoDB: Compressed tables use zlib
140922  9:33:48 InnoDB: Initializing buffer pool, size = 3.0G
InnoDB: mmap(3263692800 bytes) failed; errno 12
140922  9:33:48 InnoDB: Completed initialization of buffer pool
140922  9:33:48 InnoDB: Fatal error: cannot allocate memory for the buffer pool
140922  9:33:48 [ERROR] Plugin 'InnoDB' init function returned error.
140922  9:33:48 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
140922  9:33:48 [ERROR] Unknown/unsupported storage engine: InnoDB
140922  9:33:48 [ERROR] Aborting

I have 16G of memory and want to enable optimal use of my memory for our high transaction, Saas platform. Could you advise at your earliest?


1 comment
  • Hey there, are we sure that there's enough memory available to increase the innodb_bugger_pool_size?

    The error InnoDB: mmap(3263692800 bytes) failed; errno 12 occurs when the kernel is unable to allocate the requested amount of memory (see:

    Check the output of free -h to check the server's memory usage.

    If there isn't enough free memory use a program like top to see which programs are using what.

    That's the first step really, and depending on what that brings to light will determine what the next step is!

1 Answer

Hi there,

The output of Top is typically ....

Tasks: 111 total, 1 running, 110 sleeping, 0 stopped, 0 zombie
Cpu(s): 0.0%us, 0.0%sy, 0.0%ni, 99.9%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
Mem: 16563068k total, 811032k used, 15752036k free, 98660k buffers
Swap: 8388604k total, 0k used, 8388604k free, 404040k cached


6669 mysql 20 0 2420m 205m 7264 S 0 1.3 1:12.93 mysqld

11585 root 20 0 0 0 0 S 0 0.0 0:00.02 kworker/1:0

1 root 20 0 3540 1896 1288 S 0 0.0 0:01.37 init

2 root 20 0 0 0 0 S 0 0.0 0:00.01 kthreadd

Our installation didnt have swap which ive enabled(8Gigs) but i still cannot increase the innodb buffer to beyond 2G. Is there something else we need doing?

Read the link but amok nor top point to anything conclusive. was hoping you could let me know if there are any kernel parameters set by DO that we may need to check/undo?

Would really appreciate feedback.


  • Hey, hmm. Well I doubt this is the case but you running a 64- or 32-bit distro?

    Beyond that I'm not sure, my knowledge of the area is quite limited. Maybe someone else can pickup from where we've got to and help you to solve this as it does seem unusual. I'll keep an eye out though and will let you know if I think of anything.

Have another answer? Share your knowledge.