Hy i want to increase uploadmaxfilesize and postmaxsize to 200M. I’ve tried to set in php.ini (etc/php5/apache2/php.ini) this two values, i’ve restart apache with the command sudo service apache2 restart, but i don’t upload file exceed 8M, some suggestion?

Thanks
Mike

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
3 answers

@michelenfl

If the standard location for php.ini isn’t working, one quick way to find which php.ini is being loaded is by creating a temporary file named info.php and within it, place:

<?php phpinfo();

Save and the browse to that file using your browser of choice. You’ll want to modify the php.ini that is showing as Loaded Configuration File. For me, that’s the sixth row from the top.

Once you’ve located the correct file, delete the info.php file, make the changes needed to php.ini and then restart Apache once again.

Hello,

You can create a php info file in order to check the current values and check which is the php.ini file in use. Create the following file in your public_hmtl folder - phpinfo.php and put the following code inside it:

<?php
phpinfo();
?>

You can also use the following command in order to find the location of the php.ini file:

php -i | grep php.ini

The output will be:

Configuration File (php.ini) Path => /etc/php/7.2/cli
Loaded Configuration File => /etc/php/7.2/cli/php.ini

Then check for the current value of uploadmaxfilesize you can also check which is the configuration file - php.ini that is currently used and apply the changes there (if the site using the global php.ini file and you change the values for these settings this will make the changes globally for all sites). Ideally you would like to have the following values:

upload_max_filesize = 200M

You also need to restart your web server in order the changes to take effect.

Hope that this helps!
Regards,
Alex

Submit an Answer