Ubuntu 16.04 running nginx and php7.

I’ve tried multiple changes to the fpm/php.ini to increase ‘uploadmaxsize’ and 'postmaxsize’, but none of my changes appear in a phpinfo() that I added to the webserver.

I located all the other php.ini ’s that are on my server and updated them to match, but no changes seem to get pushed to the server after restarting php and nginx.

In all of the ini files, I have
upload_max_size 20m;
post_max_size 25m;

My nginx configuration has a much higher value for clientmaxbody_size than either of these values, but no changes successfully appear in phpinfo().

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
4 answers

Ended up reinstalling php and nginx. After doing so, I was able to modify the configurations and restart with changes appearing successfully.

sudo service nginx restart && sudo service php7.0-fpm restart

This will restart both services and load the new configurations. If there are any errors the restart will fail.

make a new file with name php.php and add the code

<?php

phpinfo();

and share the output

Hello,

Hello,

You can create a php info file in order to check the current values and check which is the php.ini file in use. Create the following file in your public_hmtl folder - phpinfo.php and put the following code inside it:

<?php
phpinfo();
?>

You can also use the following command in order to find the location of the php.ini file:

php -i | grep php.ini

The output will be:

Configuration File (php.ini) Path => /etc/php/7.2/cli
Loaded Configuration File => /etc/php/7.2/cli/php.ini

Then check for the current value of uploadmaxfilesize you can also check which is the configuration file - php.ini that is currently used and apply the changes there (if the site using the global php.ini file and you change the values for these settings this will make the changes globally for all sites). Ideally you would like to have the following values:

upload_max_filesize = 64M

You also need to restart your web server in order the changes to take effect.

Hope that this helps!
Regards,
Alex

Submit an Answer