I have a new error now for [https://millerfuresh.com]

Index of / …Port 443

I have tried the following to fix:

I looked in apache2.conf.

In Filezilla:

I created a directory /public_html to put the index.html file in
I also changed the remote site in Filezilla to : /var/www/millerfuresh.com[Example link](http://)

I found this on stack overflow and the DO tutorial but it didnt work for me:
sudo a2enmod usedir
sudo service apache2 reload
sudo mkdir /publichtml
sudo chown -R $USER:$USER /publichtml
sudo chmod -R 755 ~/public_html

How can I fix it? Thank You!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi there @millerfuresh,

It looks like that your website loads as expected via HTTP on port 80 but it does not show the correct content on port 443 via HTTPS.

What you need to do is to copy the configuration from your port 80 Virtual Host and carry it over the Virtual Host for port 443.

With Apache on Ubuntu, you can find your Virtual Hosts at: /etc/apache2/sites-enabled/.

If you are not sure, feel free to share the contents of both virtual hosts config files here.

Regards,
Bobby

  • I have added this to the config file

    <VirtualHost *:80>
    ServerAdmin webmaster@localhost
    ServerName millerfuresh.com
    ServerAlias www.millerfuresh.com
    DocumentRoot /var/www/millerfuresh.com
    ErrorLog ${APACHELOGDIR}/error.log
    CustomLog ${APACHELOGDIR}/access.log combined
    </VirtualHost>

    <VirtualHost *:443>
    ServerAdmin webmaster@localhost
    ServerName millerfuresh.com
    ServerAlias www.millerfuresh.com
    DocumentRoot /var/www/millerfuresh.com
    ErrorLog ${APACHELOGDIR}/error.log
    CustomLog ${APACHELOGDIR}/access.log combined
    </VirtualHost>

    But I am still getting the same error.
    Or do I need to create 2 separate files? I could not see how to create two separate files.

    Thank you!

Submit an Answer