Question

Index.php blank page NGINX

  • Posted on December 18, 2014
  • EverywhereSeanAsked by Sean Do

My index.php is giving me a blank page, but other .php files works just fine. I’m guessing it’s something in NGINX config?

server {
        listen 80 default_server;
        listen [::]:80 default_server ipv6only=on;

        root /srv/www/XXXX/public_html;
        index index.php index.html index.htm;

        server_name XXXX;

        location / {
                try_files $uri $uri/ =404;
        }

        error_page 404 /404.html;
        error_page 500 502 503 504 /50x.html;
        location = /50x.html {
                root /srv/www/XXXX/public_html;
        }

        location ~ \.php$ {
                try_files $uri =404;
                fastcgi_split_path_info ^(.+\.php)(/.+)$;
                fastcgi_pass unix:/var/run/php5-fpm.sock;
                fastcgi_index index.php;
                fastcgi_param SCRIPT_NAME $document_root$fastcgi_script_name;
                include fastcgi_params;
        }
}

Do you see anything that I’m missing for this occur?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

A blank page usually means that a PHP error has occurred. Check nginx’s log file for errors:

sudo tail /var/log/nginx/error.log

add this to location directive. This will fix the issue. Trust me. Don’t look for any options or google for suggestions. fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;

Hello,

try to change the location / from:

location / {
try_files $uri $uri/ =404;
}

to

location / {
try_files $uri $uri/ /index.php?q=$uri&$args;
}