index.php code being displayed in my homepage.

January 26, 2018 3.2k views
WordPress Ubuntu 16.04

Ok now I am getting a weird error type,If i go to my homepage I am getting a php code,the code is

<?php
/**

  • Front to the WordPress application. This file doesn’t do anything, but loads
  • wp-blog-header.php which does and tells WordPress to load the theme. *
  • @package WordPress */

/**

  • Tells WordPress to load the WordPress theme and output it. *
  • @var bool */ define(‘WPUSETHEMES’, true);

/** Loads the WordPress Environment and Template */
require( dirname( FILE ) . ’/wp-blog-header.php’ );

what the heck is this suppose to mean? I am totally lost.I contacted the support team they told me to check this link http://thisinterestsme.com/php-displayed-in-browser/ and I did everything seems to be fine,Php is installed,I restarted apache many times,what else is missing? any help is appreciated.

Thank you.

3 Answers

Hey, found your question while having the same issue (when upgrading to Ubuntu 18.04.1).

In my case, it seems the PHP module was not enabled in Apache, so the following command had to be run:

sudo a2enmod php7.2

After that, restart the Apache2 service:

sudo systemctl restart apache2

That would be it. I hope it works for you!

For any one having this trouble this is what I did,

i)First Run this two code,

sudo apt-get install libapache2-mod-php
and
sudo service apache2 reload

ii)and after this if you get error like “Your PHP installation appears to be missing the MySQL extension which is required by WordPress.” then run the next two commands(this is meant for php 7),

sudo apt-get install php5-mysqlnd-ms
and
sudo service apache2 reload

This should fix the problem.

I stopped using Apache. Now I am running my site with Nginx and I am happy with it!!

Thanks for all the reply.

Have another answer? Share your knowledge.