Im looking to install the ingress controller on a DO managed K8 cluster.
Im following : https://www.digitalocean.com/community/tutorials/how-to-set-up-an-nginx-ingress-with-cert-manager-on-digitalocean-kubernetes

Currently at the stage of installing Tiller (via https://www.digitalocean.com/community/tutorials/how-to-install-software-on-kubernetes-clusters-with-the-helm-package-manager) However, when I try to run the following, I get an error about it trying to hit the loopback. Like so,

root@abc123:/tmp# helm init --service-account tiller
$HELM_HOME has been configured at /root/.helm.
Error: error installing: Post http://localhost:8080/apis/extensions/v1beta1/namespaces/kube-system/deployments: dial tcp 127.0.0.1:8080: connect: connection refused

Thanks,

edited by AHA

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi there!

Do you currently have a working kubectl binary configured? Helm should use your currently configured kubectl:

From the helm docs (https://helm.sh/docs/install/#easy-in-cluster-installation):
The easiest way to install tiller into the cluster is simply to run helm init. This will validate that helm’s local environment is set up correctly (and set it up if necessary). Then it will connect to whatever cluster kubectl connects to by default (kubectl config view).

I would check that kubectl is configured properly.

Regards,

John Kwiatkoski
Senior Developer Support Engineer

  • Thanks. my Kubectl is working correctly and is set up. Hence the confusion.

    # kubectl config view
    apiVersion: v1
    clusters:
    - cluster:
        certificate-authority-data: DATA+OMITTED
        server: https://b4f4ed8d-4fe0-46c9-9c5a-25c273cdf3be.k8s.ondigitalocean.com
      name: do-sfo2-k8s-1-15-3-do-2-sfo2-1568294480587
    contexts:
    - context:
        cluster: do-sfo2-k8s-1-15-3-do-2-sfo2-1568294480587
        user: do-sfo2-k8s-1-15-3-do-2-sfo2-1568294480587-admin
      name: do-sfo2-k8s-1-15-3-do-2-sfo2-1568294480587
    current-context: do-sfo2-k8s-1-15-3-do-2-sfo2-1568294480587
    kind: Config
    preferences: {}
    users:
    - name: do-sfo2-k8s-1-15-3-do-2-sfo2-1568294480587-admin
      user:
        client-certificate-data: REDACTED
        client-key-data: REDACTED
    
    # helm init
    $HELM_HOME has been configured at /root/.helm.
    Error: error installing: Post http://localhost:8080/apis/extensions/v1beta1/namespaces/kube-system/deployments: dial tcp 127.0.0.1:8080: connect: connection refused
    
Submit an Answer