Question

Initial password for CoreOS?

Posted January 23, 2015 27k views

Hi guys,

Probably a total noob question, but I am having trouble getting my ssh into a new CoreOS droplet. I’m on Mac 10.9, Firefox 35, and just using Terminal

1) I create my ssh key
2) I upload public key into digitalocean website
3) I create a new CoreOS droplet and choose the SSH key i uploaded in (2)
4) I try to ssh in using [ssh -vT username-from-ssh-creation@droplet IP address

Everything seems to go fine until:

debug1: Found key in /Users/sdiggly/.ssh/knownhosts:2
debug1: ssh
rsaverify: signature correct
debug1: SSH2
MSGNEWKEYS sent
debug1: expecting SSH2
MSGNEWKEYS
debug1: SSH2
MSGNEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2
MSGSERVICEREQUEST sent
debug1: SSH2MSGSERVICEACCEPT received
debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /Users/sdiggly/.ssh/id
rsa
debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug1: Trying private key: /Users/sdiggly/.ssh/id_dsa
debug1: Next authentication method: keyboard-interactive
debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug1: Next authentication method: password

I have NO idea what password that is! I didn’t create my ssh key with a password.

Also, when I try to use the virtual console to login, i’m also asked for a password

And finally, I can’t seem to get the single user mode working. I’m not sure if i’m just not fast enough, or what, but I never seem to catch the boot in time to hit “2”

Any ideas?? I’m sure i’m being an idiot here, but I can’t figure out where I’m going wrong

Thank you!
sdiggly

5 comments

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
3 answers

CoreOS is configured to only accept connections using SSH keys, not passwords. The default user is core So you would connect to your droplet using:

ssh core@your.droplet.ip

The -C option to ssh-keygen isn’t necessarily a username. From its man page:

     -C comment
             Provides a new comment.

Personally, I use that field to denote the username and computer name of the local computer not the server. So is the key is for my user foo on my personal laptop, I’d create a key with ssh-keygen -t rsa -C "foo@laptop"

Ha, awesome! Thank you asb! You are awesome! “core” vs “root”…told you it was a noob issue!

Thank you again!

There’s no such thing as “ssh creation”. What username are you using?

Submit an Answer