Install mod_spdy on Apache 2.4

  • Posted August 12, 2014

Hi, I don’t think that I am the only one which has this issue. When I try to install mod_spdy, I’ve got some dependencies issues.

Here is the output :

$ dpkg -i mod-spdy-beta_current_amd64.deb 
Selecting previously unselected package mod-spdy-beta.
(Reading database ... 111842 files and directories currently installed.)
Preparing to unpack mod-spdy-beta_current_amd64.deb ...
Unpacking mod-spdy-beta ( ...
dpkg: dependency problems prevent configuration of mod-spdy-beta:
 mod-spdy-beta depends on apache2.2-common; however:
  Package apache2.2-common is not installed.

dpkg: error processing package mod-spdy-beta (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:

I even tried to downgrade apache to 2.2 but the digital ocean mirrors doesn’t provide that version unfortunately.

If anyone has a clue how to fix this issue, please let me know, Thanks


On Ubuntu 14.04 x64 vmlinuz-3.13.0-32-generic with LAMP and php5-fpm, I got it working with this guide

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Yet another server migration \o/

I’ll do that then. Thanks for the trick.

Judging from this lengthy bug report, mod_spdy does not yet support Ubuntu 14.04 or Apache 2.4 The simplest solution is to use Ubuntu 12.04 if you need mod_spdy as it ships with Apache 2.2.