root@ip-172-31-6-112:/var/pentaho/biserver-ce# ./start-pentaho.sh
WARNING: Using java from path
DEBUG: PENTAHOJAVAHOME=
DEBUG: _PENTAHO
JAVA=java
Using CATALINABASE: /var/pentaho/biserver-ce/tomcat
Using CATALINA
HOME: /var/pentaho/biserver-ce/tomcat
Using CATALINATMPDIR: /var/pentaho/biserver-ce/tomcat/temp
Using JRE
HOME: /usr
Using CLASSPATH: /var/pentaho/biserver-ce/tomcat/bin/bootstrap.jar:/var/pentaho/biserver-ce/tomcat/bin/tomcat-juli.jar
Tomcat started.

tomcat logs file also add

OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0
OpenJDK 64-Bit Server VM warning: INFO: os::commit_memory(0x00000006c0000000, 1431699456, 0) failed; error=‘Cannot allocate memory’ (errno=12)

There is insufficient memory for the Java Runtime Environment to continue.

Native memory allocation (mmap) failed to map 1431699456 bytes for committing reserved memory.

An error report file with more information is saved as:

/var/pentaho/biserver-ce/tomcat/bin/hserrpid19303.log

OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0
OpenJDK 64-Bit Server VM warning: INFO: os::commit_memory(0x00000006c0000000, 1431699456, 0) failed; error='Cannot allocate memory’ (errno=12)

There is insufficient memory for the Java Runtime Environment to continue.

Native memory allocation (mmap) failed to map 1431699456 bytes for committing reserved memory.

An error report file with more information is saved as:

/var/pentaho/biserver-ce/tomcat/bin/hserrpid26047.log

OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0
OpenJDK 64-Bit Server VM warning: INFO: os::commit_memory(0x00000006c0000000, 1431699456, 0) failed; error='Cannot allocate memory’ (errno=12)

There is insufficient memory for the Java Runtime Environment to continue.

Native memory allocation (mmap) failed to map 1431699456 bytes for committing reserved memory.

An error report file with more information is saved as:

/var/pentaho/biserver-ce/tomcat/bin/hserrpid2029.log

OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0
OpenJDK 64-Bit Server VM warning: INFO: os::commit_memory(0x00000006c0000000, 1431699456, 0) failed; error='Cannot allocate memory’ (errno=12)

There is insufficient memory for the Java Runtime Environment to continue.

Native memory allocation (mmap) failed to map 1431699456 bytes for committing reserved memory.

An error report file with more information is saved as:

/var/pentaho/biserver-ce/tomcat/bin/hserrpid2147.log

1 comment

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

Use a bigger droplet, like it says: Not enough RAM

Submit an Answer