Hi there,

Can someone help me with installing Slanger on my Ubuntu VPS. I get stuck on gem install slanger

I’ve got the error:
ERROR: While executing gem ... (Gem::DependencyError)
Unable to resolve dependencies: slanger requires rack (~> 1.4.5); thin requires rack (~> 1.0); sinatra requires rack (~> 1.5); rack-protection requires rack (>= 0)

Thanks for your help!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

When I need to install new gems I start off by installing a few packages that can be helpful:

apt-get update;
apt-get install ruby-dev build-essential

If you installed gems like sinatra or rack from the Ubuntu repositories they may be too old to support the gem you are now trying to install. I would then recommend removing any packages like ruby-sinatra and installing them instead via gem install sinatra

Submit an Answer