Install using Vagrant with shell script set to privileged: false not working?

January 14, 2015 3.9k views

I setup my server using Vagrant (Ubuntu 14 64 bit), I install my packages using two shell scripts. One installs all the packages needed and the other one install packages using npm and is set to privileged: false. It looks like this:

  config.vm.provision :shell, :path => "", privileged: false

When I run my Vagrant box on my local, it works fine, all packages is installed and the packages using npm.

But when I run it deploying to digital ocean, it fails with node: Permission denied. I guess it happens because the user that tries to install via npm is root and that doesn't work for npm (if I install it manually, I need to create another user to run and install using npm).

What is the best way to setup your Vagrant file to install node and then run npm so it works on Ubuntu?

The Vagrant file I'm using is (not including the digital ocean info):


1 comment
  • I was installing node using nvm changed to use apt-get and everything works fine.

    However would be nice if you could run as privileged: false

1 Answer

Looking at an older revision of your repo, it looks like you need to add the --unsafe-perm flag to the npm install commands. From the npm config docs:


  • Default: false if running as root, true otherwise
  • Type: Boolean Set to true to suppress the UID/GID switching when running package scripts. If set explicitly to false, then installing as a non-root user will fail.
Have another answer? Share your knowledge.