Question

Installation problem on a Droplet

Hi DigitalOcean,

I was trying to do an apt install and got the following error repeated over ad over.

“It is held by process 1 Waiting for cache lock: Could not get lock /var/lib/dpkg/lock-frontend.”

I googled it, and was told that an update was probably taking place. I’ve waited and tried again several times. Do I just need to wait longer? Or does DigitalOcean for some reason not like tmux installations?

Thank you for your time norm


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello @normdunlop

Usually, this is the case, have you tried checking if there is already an existing process using the ps command? You can check this with the following command:

  1. ps aux | grep -i apt

Regards