Question

Installed LetsEncrypt to get SSL and now my website is not reachable

I am following this tutorial https://www.digitalocean.com/community/tutorials/how-to-secure-apache-with-let-s-encrypt-on-ubuntu-18-04 and after I followed the steps and went to my website it was gone. I tried to log into the WordPress admin panel and the webpage and got a 403 error. I realized I forgot to add domain.com (the .com part) so I repeated the steps. Now I get “Success! The your_domain virtual host is working!” when I go to domain.com, instead of my wordpress site I built. What happened to my website!?

I don’t know what to do help would be really appreciated.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi there @vinnyp96,

Can you share the content of your Apache virtual host? To do that you could first find the file with the following command

  1. ls -lah /etc/apache2/sites-enabled

There you should see 2 files associated with your domain name, one for your SSL Vhost and one for the non-SSL Vhost.

Then use the cat command to display the content:

  1. sudo cat /etc/apache2/sites-enabled/your-domain.conf

Feel free to share the output here.

Also please check your Apache error log with the following command:

  1. sudo tail -100 /var/log/apache2/error.log

Regards, Bobby

To add one going to www.domain.com all I see is “Success! The your_domain virtual host is working!”

Before I tried adding SSL and did all these steps, going to http://IP-address/wp-admin/ resulted in a WordPress login page and then I could edit my website. Now I get:

Not Found

The requested URL was not found on this server.

Apache/2.4.29 (Ubuntu) Server at <DOMAIN>.com Port 443

Hi @bobbyiliev,

root@XXX:~# sudo cat /etc/apache2/sites-enabled/<DOMAIN>.com-le-ssl.conf 
<IfModule mod_ssl.c>
<VirtualHost *:443>
	ServerAdmin webmaster@localhost    
	ServerName <DOMAIN>.com    
	ServerAlias www.<DOMAIN>.com    
	DocumentRoot /var/www/<DOMAIN>.com    
	ErrorLog ${APACHE_LOG_DIR}/error.log    
	CustomLog ${APACHE_LOG_DIR}/access.log combined

Include /etc/letsencrypt/options-ssl-apache.conf
SSLCertificateFile /etc/letsencrypt/live/<DOMAIN>.com/fullchain.pem
SSLCertificateKeyFile /etc/letsencrypt/live/<DOMAIN>.com/privkey.pem
</VirtualHost>
</IfModule> 

Also to add on: going to www.<domain>.com I get:

Success! The your_domain virtual host is working!

Going to http://<IP>/wp-admin/ I used to be able to login to Wordpress and edit my site, now I get:

Not Found

The requested URL was not found on this server.

Apache/2.4.29 (Ubuntu) Server at <DOMAIN>.com Port 443