Question

installed nginx and php5-fpm on ubuntu server and then installed magento and i get white screen

  • Posted August 31, 2014

installed nginx and php5-fpm on ubuntu server and then installed magento and i get white screen nothing else on it vertual host config

        listen 80 default_server;
        listen [::]:80 default_server ipv6only=on;

        root /var/www/example.com/html/html;
        index index.html index.htm index.php;

php config in it is

  location ~ \.php$ {
        #       fastcgi_split_path_info ^(.+\.php)(/.+)$;
        #       # NOTE: You should have "cgi.fix_pathinfo = 0;" in php.ini
        #
        #       # With php5-cgi alone:
                fastcgi_pass 127.0.0.1:9000;
        #       # With php5-fpm:
        #       fastcgi_pass unix:/var/run/php5-fpm.sock;
                fastcgi_index index.php;
                include fastcgi_params;
                fastcgi_param  SCRIPT_FILENAME    $document_root$fastcgi_script$
        }

but it gives white screen when i type in the ip address . my fevicon and the title shows

i have installed all the php required extension – mysql, gd, mcrypt, curl

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

It looks like there is a typo on your fastcgi_param line. It should be:

fastcgi_param  SCRIPT_FILENAME  $document_root$fastcgi_script_name;

Magento uses a fairly standard LEMP stack. This tutorial should help you get up and running:

How To Install Linux, nginx, MySQL, PHP (LEMP) stack on Ubuntu 14.04

If you’re still running into issues after that, check for any messages in your Nginx and PHP error logs:

/var/log/nginx/error.log
/var/log/php5-fpm.log

thanks for the anwer, but i could not make it run .

http://128.199.134.90/index.php/install/ it gives http 404 error

the nginx error log says code 2014/09/03 01:43:21 [emerg] 5868#0: invalid host in upstream “/var/run/php5-fpm.sock” in /etc/nginx/sites-enabled/example.com:81 2014/09/03 01:43:34 [emerg] 5887#0: invalid host in upstream “/var/run/php5-fpm.sock” in /etc/nginx/sites-enabled/example.com:81 2014/09/03 01:45:22 [emerg] 5910#0: invalid host in upstream “/var/run/php5-fpm.sock” in /etc/nginx/sites-enabled/example.com:81 2014/09/03 01:45:26 [emerg] 5929#0: invalid host in upstream “/var/run/php5-fpm.sock” in /etc/nginx/sites-enabled/example.com:81 2014/09/03 01:46:20 [emerg] 5950#0: invalid number of arguments in “fastcgi_pass” directive in /etc/nginx/sites-enabled/example.com:81 2014/09/03 01:46:56 [emerg] 5971#0: invalid number of arguments in “fastcgi_pass” directive in /etc/nginx/sites-enabled/example.com:81 2014/09/03 02:07:24 [emerg] 6054#0: directive “error_page” is not terminated by “;” in /etc/nginx/sites-enabled/example.com:63