installed one click wordpress, then setup the domain name and waited 24 hour.but site is still down

August 18, 2014 3.6k views

the Support of namecheap was saying that the problem is web-hosting provider,
Resolving drive4media.com (drive4media.com)... 107.170.141.180
Connecting to drive4media.com (drive4media.com)|107.170.141.180|:80... failed: Connection refused.

9 Answers

Running nmap 107.170.141.180 show that port 80 is not open for that IP address. Is Apache running:

sudo service apache2 start

Have you set up any firewalling? If so, remember to open port 80. What's the output of:

sudo netstat -plunt

root@Drive4media:~# sudo service apache start
apache: unrecognized service

root@Drive4media:~# sudo netstat -plunt
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 127.0.0.1:3306 0.0.0.0:* LISTEN 895/mysqld
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 819/sshd
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 984/master
tcp6 0 0 :::22 :::* LISTEN 819/sshd
tcp6 0 0 ::1:25 :::* LISTEN 984/master

  • Sorry, that should have been sudo service apache2 start Judging from the netstat output, Apache isn't running at all.

root@Drive4media:~# sudo service apache2 restart

  • Restarting web server apache2 [fail]
  • The apache2 configtest failed. Output of config test was: AH00526: Syntax error on line 1 of /etc/apache2/apache2.conf: Invalid command 'root@Drive4media:ServerRoot', perhaps misspelled or defined by a module not included in the server configuration Action 'configtest' failed. The Apache error log may have more information

1.it says that some error on line 1 but what the problem could be??
when i was creating the droplet(one click WP) and installed word press, i was able to see wordpress by the ip in the browser. then i setup my domain from this tut http://www.youtube.com/watch?v=FZ7CsNykw9c

  1. when i setup the domain and while it propageted i can get by the ip to the wordpress site or not ??
  • Could you post the contents of /etc/apache2/apache2.conf on a pastebin? There is some kind of syntax error there.

root@Drive4media:ServerRoot "/etc/apache2"
Mutex file:${APACHE_LOCK_DIR} default
PidFile ${APACHE_PID_FILE}
Timeout 300
KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 5
User ${APACHE_RUN_USER}
Group ${APACHE_RUN_GROUP}
HostnameLookups Off
ErrorLog ${APACHE_LOG_DIR}/error.log
LogLevel crit
IncludeOptional mods-enabled/*.load
IncludeOptional mods-enabled/*.conf
Include ports.conf

<Directory />
    Options FollowSymLinks
    AllowOverride None
    <Limit PUT DELETE CONNECT OPTIONS PATCH PROPFIND PROPPATCH MKCOL COPY MOVE LOCK $
       deny from all
    </Limit>
</Directory>

<Directory /var/www>
        Options FollowSymLinks
        AllowOverride FileInfo
</Directory>

<Directory /usr/share>
        AllowOverride None
        Require all granted
</Directory>

AccessFileName .htaccess

<FilesMatch "^\.ht">
        Require all denied
</FilesMatch>


AccessFileName .htaccess
<FilesMatch "^\.ht">
        Require all denied
</FilesMatch>


AccessFileName .htaccess

<FilesMatch "^\.ht">
        Require all denied
</FilesMatch>

LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" vhost$
LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %O" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent
IncludeOptional conf-enabled/*.conf
IncludeOptional sites-enabled/*.conf

<DirectoryMatch ^.*/wp-content/uploads/>
  AllowOverride None
  php_flag engine off
  php_admin_value engine Off
</DirectoryMatch>

<DirectoryMatch ^.*/wp-content/blogs.dir/>
  AllowOverride None
  php_flag engine off
  php_admin_value engine Off
</DirectoryMatch>

<DirectoryMatch ^.*/wp-content/blogs.dir/>
  AllowOverride None
  php_flag engine off
  php_admin_value engine Off
</DirectoryMatch>

#<DirectoryMatch ^.*/wp-admin/>
#  AuthType Basic
#  AuthName "Restricted Area"
#  AuthUserFile /etc/apache2/.htpasswd
#  Require valid-user
#</DirectoryMatch>
<VirtualHost *:80>
   ServerAdmin webmaster@Drive4media.com
   DocumentRoot /var/www/Drive4media.com/
   Servername Drive4media.com
   ServerAlias www.Drive4media.com
   ErrorLog ${APACHE_LOG_DIR}/error.log
   Customlog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>
  • Is the first line actually:

    root@Drive4media:ServerRoot "/etc/apache2"
    

    If so that's definitely a problem. It should be:

    ServerRoot "/etc/apache2"
    

    Change it and start Apache again with: sudo service apache2 start

root@Drive4media:~# sudo service apache2 start

  • Starting web server apache2 AH00112: Warning: DocumentRoot [/var/www/Drive4media.com/] does not exist AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message

i think its ok

firest thanks you for the helpppppppppp:)))sorry i nob
when i go to ip address is says Forbidden
You don't have permission to access / on this server?

second when i go to my doamin name it says This webpage is not available?

  • That seems to be due to this error:

    * Starting web server apache2 AH00112: Warning: DocumentRoot [/var/www/Drive4media.com/] does not exist
    

    Does that folder exist? Normally, the WordPress one-click installs WordPress into /var/www/ The DocumentRoot setting should point to the folder where it is installed. Normally:

    DocumentRoot /var/www/
    

thanks for the help i appreciate it :))
i destroyed this droplet and start all over again with new one click WP.

i installed new droplet of one click wordpress. then after i put the pass from email to the putty is ask me change the pass,as i put new pass and hit ENTER after 2-3 sec it says connection closed by remote host???

putty : connection closed by remote host

I am getting :
Forbidden

You don't have permission to access /php5-fcgi/index.php on this server.

Have another answer? Share your knowledge.