Installing newer HWE version does not make message go away

August 1, 2014 2.5k views

Every time I SSH to my Ubuntu 12.04 server i get this message.

To upgrade to a supported (or longer supported) configuration:

  • Upgrade from Ubuntu 12.04 LTS to Ubuntu 14.04 LTS by running: sudo do-release-upgrade


  • Install a newer HWE version by running: sudo apt-get install linux-generic-lts-trusty linux-image-generic-lts-trusty

I dont feel like doing an upgrade to 14.04 so I choose to do the second option. But after success I still get this message every time I log in

2 Answers

Ubuntu will display that message if the file /var/lib/update-notifier/hwe-eol exists. I've seen a few reports that it isn't being properly updated after people upgrade their kernel version. You can safely remove that file. It will be recreated on a reboot if you indeed still have the have the old kernel in use.

If that's the case, make sure you've set the kernel in the DigitalOcean control panel to match the one that is installed on the droplet. The virtualization that we use requires that a matching kernel be found installed in your libraries in the OS and is also found on the hypervisor settings for your droplet, which is set through the control panel.

  • uname -r tells you the version the control panel is using
  • ls -lah /lib/modules shows you the libraries you have installed

To change it in the control panel, you need to poweroff the machine. Then go to the control panel, click on the droplet, click "settings" and then "Kernel". Next click the list and find the right version that matches your kernel libraries .e.g *Ubuntu 14.04 x64 3.13.0-30 Finally boot the droplet using the control panel.

  • I did the upgrade

    sudo apt-get install linux-generic-lts-trusty linux-image-generic-lts-trusty

    then i run

    ls -lah /lib/modules


    The only image i find with that number (3.13.0-36) )is saying Ubuntu 14.04. Should i choose that one?



    I tried switching the image in the settings to the 3.13.0-36 but it did not seem to work. So i tried to change it back but that did not work either. So now my machine wont boot anymore.

    How can i get this back online?

I had the same problem, and had to select a different kernel in the control panel. These instructions were most helpful, thanks!

Have another answer? Share your knowledge.