Question

Installing PHP Trader Extension

Posted May 20, 2015 8.7k views
PHPLAMP Stack

Hi there I’m trying to install a PHP Extension and am having trouble. The Extension is here: http://php.net/manual/en/book.trader.php .

How do i install via terminal?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

Hi

Do these instructions still apply in Jan 2018?

I am really thinking about the php5-dev

Thanks.

  • Yes it indeed depends on the version of PHP you run. You can find out the version by typing this in the command line:

    php --version
    

    To keep it easy you can simply leave out the version number which will make your OS query the correct one (in most cases) from the default repositories. The whole installation would look like this:

    apt-get install php-pear php-dev libcurl3-openssl-dev
    pecl install trader
    

This package is handled by PECL. To install it you can..

sudo apt-get update
sudo apt-get install php-pear php5-dev 
pear install trader
Submit an Answer