Question

Installing PHPMyAdmin

I pre-installed LAMP with my droplet and then i opened terminal and put in “sudo apt-get install phpmyadmin” and it ran like it was working right. I hit y to confirm and then i restarted my droplet and tried to access /phpmyadmin on my server and it says “The requested URL /phpmyadmin was not found on this server.” I did indeed install it on apache 2 as i have seen some articles about that. Any details why i cannot access it?

Regards, Jarrod


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi @jarrodestepp16

Did you remember to tick the apache2 option in the installation wizard? It’s not the most user friendly interface, so it’s easy to make a mistake there.

You should have a phpMyAdmin configuration located in /etc/apache2/conf-enabled/ if the installation was successful - and you shouldn’t need to restart the entire server, it should be enough by restarting Apache.

If you want to reinstall and see the configuration wizard again, you need to remove and purge your current installation of phpMyAdmin first:

sudo apt-get --purge remove phpmyadmin

You can read more in this tutorial: https://www.digitalocean.com/community/tutorials/how-to-install-and-secure-phpmyadmin-on-ubuntu-16-04

This info helped me:

Warning: When the first prompt appears, apache2 is highlighted, but not selected. If you do not hit Space to select Apache, the installer will not move the necessary files during installation. Hit Space, Tab, and then Enter to select Apache.

I face the same problem and i do not find phpmyadmin config file in path :etc/apache2/conf-enabled

(The installation process actually adds the phpMyAdmin Apache configuration file into the /etc/apache2/conf-enabled/ directory, where it is automatically read.)