Installing Snorby with Nginx

October 22, 2014 2.4k views

I'll go ahead and say I am about three months into web hosting. I use Ajenti V to setup most of my stuff, because I'm making the network for a school.

The normal way I go about installing it would be just to add the folder and MySQL, but it seems this one is VERY different. What's worse, their fourms won't send me an email activation link, so I had to come here to try to find out.

Question: How do I install without changing the current configuration settings already setup with Ajenti and Nginx?

1 Answer

It sounds like the types of sites you've mostly worked with so far are traditional PHP applications like WordPress. Snorby is based on an entirely different programing language with a different framework and approach to deployment, Ruby on Rails.

You might want to read a few tutorials under the Ruby on Rails tag here and test some things out to get more comfortable before trying to install this on your production server. This tutorial should point you in the right direction. It goes through the basics of deploying a Rails app on top of Nginx:

Taking a look at Snorby specifically, it looks like it follows a fairly standard Rails set up. Have you tried the installation steps on their homepage? What are the specific problems you've run into? I'd suggest spinning up a new droplet just to test it out first.

by Juraj Kostolanský
Deploy your Rails application with Passenger and Nginx on Ubuntu 14.04.
  • Looks Great! Thanks for helping me btw :)

    I have not tried to set it up yet, mainly because ajenti manages all of my domains.

  • Okay so I have ruby installed, but the following actions in the tutorial you provided would disable the current ajenti setup. I already have 4 websites up and running, and would like to get ruby running along side them.

    My end goal is to install foreman and snorby. If you think you might be able to help without it being to much of a bother :)

  • Also installing ruby I got the following error.

    root@PassItOn-Main:/root/ruby/ruby-2.1.3# ruby -v Command 'ruby' is available in '/usr/local/bin/ruby' The command could not be located because '/usr/local/bin' is not included in the PATH environment variable. ruby: command not found root@PassItOn-Main:/root/ruby/ruby-2.1.3#

  • That's weird. /usr/local/bin should be included in the PATH variable. Edit /etc/environment and add :/usr/local/bin at the end of the file before the quotation mark.


    Then log out and log back in.

  • The file you're editing is /etc/environment. You can run the following command that fixes the variable without having to open the file in an editor:

    sudo sed -i 's/"$/:\/usr\/local\/bin"/' /etc/environment
  • I feel bad asking that question and then rereading the comment I was referring to. Kay, I went ahead and did it by vi, (Studying vi in college and need the practice) Do I need to restart the server or just the terminal session?

  • Okay, so finished that up, but now it gives me the same error.

    now if I do "./ruby -v" it works fine.

Have another answer? Share your knowledge.